Could ARMv4T support be added?

Currently, LLD doesn’t support ARMv4T. The oldest ARM supported is ARMv5T. Because of this, when building a program for the GameBoy Advance the GNU Binutils linker is required.

Would it be possible for LLD to support to be expanded in this area?