Clangd is not indexing background

hi all,
I am coding with vim + ycm plugin which use clangd as a lsp, but yestorday my vim can not goto source code correctly, only goto definition in header files, also I can not find the index file either in project root/.cache/clangd or $HOME/.cache/clangd. Plz help me, thanks.

vim version: 8.2
ycm version: git commit id 7c4d05375a09a871f618f9688c7af517d4e69b76
clangd version: 12.0.1

ycm configuration:

let g:ycm_use_clangd = 1                                                                                     
let g:ycm_clangd_binary_path = '/home/syb/test/clang+llvm-12.0.1-x86_64-linux-gnu-ubuntu-/bin/clangd'        
let g:ycm_clangd_args = ['--background-index', '-pretty', '-j=10']                                           
let g:ycm_clangd_uses_ycmd_caching = 0                                                                       
let g:ycm_confirm_extra_conf = 1                                                                             
let g:ycm_max_diagnostics_to_display = 0                                                                     
let g:ycm_autoclose_preview_window_after_insertion = 1                                                       

ycm log:

Printing YouCompleteMe debug information...
-- Resolve completions: On demand
-- Client logfile: /tmp/ycm_dchokq0m.log
-- Server Python interpreter: /usr/bin/python3
-- Server Python version: 3.6.9
-- Server has Clang support compiled in: False
-- Clang version: None
-- No extra configuration file found
-- C-family completer debug information:
--   Clangd running
--   Clangd process ID: 25625
--   Clangd executable: ['/home/syb/test/clang+llvm-12.0.1-x86_64-linux-gnu-ubuntu-/bin/clangd', '--background-index', '-pretty', '-j=10', '-header-insertion-decorators=0', '-log=verbose']
--   Clangd logfiles:
--     /tmp/clangd_stderrrqjbzblt.log
--   Clangd Server State: Initialized
--   Clangd Project Directory: /workspace/sunyunbo/src/cpp/cmake_project_template
--   Clangd Settings: {}
--   Clangd Compilation Command: False